Knowledge Base

03.07.11

weave minimal server stops working with firefox 5.0 / FF5

I've been running the minimal weave server from tobyelliott.wordpress.com/2009/09/11/weave-minimal-server/ for quite a while on my linux server without any problems. But since the upgrade to FF5 sync failed. The reason is, that FF5 switched the protocol from 1.0 to 1.1

 

The only change i had to do to get things working was to add in weaves index.php the version to the if clause

 

index.php, line 119:

 

change:

if ($version != '0.5' && $version != '1.0')

 

to:

if ($version != '0.5' && $version != '1.0' && $version != '1.1')

 

voila!

 



<- Zurück zur Übersicht